Clio Degraded Performance

Incident Report for Clio (AU)

Resolved

Reported performance issues and errors logging into Clio products have been resolved.
Posted May 29, 2025 - 03:18 AEST

Investigating

We are currently investigating reports of issues logging into Clio Apps and intermittent application errors.
Posted May 29, 2025 - 03:02 AEST
This incident affected: Clio (AU).