Possible Clio Degraded Performance

Incident Report for Clio (AU)

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 10:26 AEDT

Monitoring

Affected Clio Systems are recovering from the AWS outage. We will continue to monitor until all functionality is fully restored.
Posted Oct 21, 2025 - 07:47 AEDT

Investigating

Due to an AWS outage, we are currently seeing degraded performance across some of Clio's products and features. We are working on a resolution and thank you for your continued patience and understanding.
Posted Oct 21, 2025 - 04:02 AEDT
This incident affected: Clio (AU).